As you might be aware that SparkPost is going to end the support for  TLSv1.0 after June 30, 2018. To see if your server can communicate  TLSv1.1 or above the SparkPost has released new end point.

US Hosted Customers:

Check if this is your Endpoint: https://api.sparkpost.com/api/v1/

If yes replace it with following

Test Endpoint for TLS Deprecation: https://no-tlsv1-test-api.sparkpost.com/api/v1/

EU Hosted Customers:

Check if this is your Endpoint: https://api.eu.sparkpost.com/api/v1/

If yes replace it with following
Test Endpoint for TLS Deprecation: https://no-tlsv1-test-api.eu.sparkpost.com/api/v1/

Enterprise Customers with Branded Hostnames:

Check if this is your Endpoint:: https://<company_name>.api.e.sparkpost.com/api/v1/

If yes replace it with following
Test Endpoint for TLS Deprecation: https://no-tlsv1-test-<company_name>.api.e.sparkpost.com/api/v1/